В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
камилла731
камилла731
26.09.2022 08:45 •  Информатика

Написать программу, ведущую учет очков, набранных каждой командой при игре в баскетбол. количество очков, полученных в ходе игры, может быть равно 1, 2 или 3. после окончания игры выдать итоговое сообщение и указать номер команды-победительницы. окончание игры условно моделировать вводом количества очков, равного нулю. на паскаль

Показать ответ
Ответ:
HELP111111111111q
HELP111111111111q
07.07.2020 17:23
var
  commands: array [1..2] of byte;
  buf: string;

begin
  writeln('Формат ввода: (№ комманды)(пробел)(очки)');
  writeln('Например:     1 3');
  writeln('№ О');
  repeat
    readln(buf);
    if buf = '0' then break;
    commands[integer.Parse(buf[1])] += byte.Parse(buf[3]);
  until false;
  
  writeln(String.Format('Команда {0} победила во счётом {1} очк.', commands[1] > commands[2] ? 1 : 2, max(commands[1], commands[2])));
end.
0,0(0 оценок)
Ответ:
marmeladka0907
marmeladka0907
07.07.2020 17:23
Полный код не влез, в 2 комента вставил
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота