В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
tim1415320053774
tim1415320053774
07.12.2021 17:59 •  Информатика

Написать программу в ! составить процедуру, заменяющую в исходной строке символов все единицы нулями и все нули единицами. замена выполняется, начиная с заданной позиции строки.

Показать ответ
Ответ:
Varvara2001
Varvara2001
15.07.2020 20:00
Var
k:integer;
s:string;
procedure Zamena(var ss:string; p:integer);
var
i:integer;
begin
for i:=p to length(ss) do
begin
if ss[i]='1' then ss[i]:='0' else
if ss[i]='0' then ss[i]:='1';
end;
end;
begin
writeln('Введите строку: ');
readln(s);
writeln('Введите позицию с которой начинать замену: ');
readln(k);
Zamena(s,k);
writeln('Измененная строка: ',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота