В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Katyakaran
Katyakaran
13.01.2023 08:47 •  Информатика

Написать программу в си++. такая : если сумма трёх попарно различных действительных чисел x,y,z меньше единицы, то наименьшее из этих трёх чисел заменить полусуммой двух других; в противном случае заменить меньшее из x и y полусуммой двух оставшихся значений. заранее ))

Показать ответ
Ответ:
alliekw3p0144w
alliekw3p0144w
04.10.2020 00:38
//Dev-C++ 5.11

#include <iostream>
using namespace std;

int main(void)
 {float x,y,z=0;
 cin>>x>>y>>z;
 if(x+y+z<1)
  {float min=x;
  if (min>y) min=y;
  if (min>z) min=z;
  if (min==x) x=(y+z)/2;
  if (min==y) y=(x+z)/2;
  if (min==z) z=(x+y)/2;}
  else
  if(x>y) y=(x+z)/2; else x=(y+z)/2;
 cout<<x<<" "<<y<<" "<<z<<" ";
 return 0;}

Пример ввода:
1.1
2.2
3.3
Пример вывода:
2.75 2.2 3.3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота