В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
evgenyzuzev
evgenyzuzev
28.10.2022 09:58 •  Информатика

Написать программу в С++
В двумерном массиве A размерами m×n найти минимальный элемент среди положительных элементов, стоящих над главной диагональю (нулевой элемент считать положительным). Вывести на печать этот элемент и его координаты (номер строки и номер столбца). Если такого элемента не нашлось – напечатать соответствующее сообщение.

Программу писать со всеми заголовочными файлами, объявлением главной функции и комментариями.

Для ответа сформировать файл с исходным кодом приложения и скрином работы приложения.

Показать ответ
Ответ:
BNN11
BNN11
26.05.2020 13:30

Объяснение:

Var a:array [1..50,1..50] of integer;

m,n,i,j,k,max:integer;

begin

writeln ('Введи количество строк и столбцов');

readln (n,m);

for i:=1 to n do begin

for j:=1 to m do begin

a[i,j]:=random(21)-10;

write (a[i,j]:4);

end;

writeln;

end;

max:=0;

for i:=1 to n do begin

for j:=1 to m do

if a[i,j]>max then max:=a[i,j];

writeln ('Максимальный элемент ',i,' строки = ',max);

max:=0;

end;

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота