В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Bisspector
Bisspector
20.02.2021 15:12 •  Информатика

Написать программу в с++ составить программу определения значений указанных ниже линейного массива.выполнить программу для длины массива n=8 сумма обратных величин ненулевых элементов массива

Показать ответ
Ответ:
mariapopova77
mariapopova77
03.10.2020 18:24
#include <iostream>
using namespace std;
const int N = 8; //длина массива
double s = 0; //начальное значение суммы
double mas[N]; //объявляем статический массив длины N
int main()
{
    //вводим элементы массива
    for(int i = 0; i < N; ++i)
    {
        cin >> mas[i];
    }
    //пробегаемся по элементам массива
    for(int i = 0; i < N; ++i)
    {
        if(mas[i] != 0.0) //если элемент массива не равен 0
            s += 1. / mas[i]; //прибавляем значение обратного элемента к итоговой сумме
    }
    cout << s; //вывод суммы на экран
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота