В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
miraaa372
miraaa372
10.02.2022 23:40 •  Информатика

Написать программу в с++ натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая это самое число. например, число 6 является совершенным (1+2+3 = 6). найти все совершенные числа, меньшие 100 000.

Показать ответ
Ответ:
Bill542
Bill542
07.10.2020 03:11
#include <iostream>
using namespace std;

int main(){
    int s;
    for (int i=2; i<=100000; i++){
    s = 1;
    for (int j=2; j<=i/2; j++)
    if (i % j == 0) s+=j;
    if (s == i)
    cout << i << " ";
    }
    return 0;
}

Результат:
6 28 496 8128
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота