Написать программу в Python. Разработайте программу, с которой в главном окне размещаются две кнопки с названиями "Ввести" и "Деление". После нажатия первой кнопки два числа вводятся с клавиатуры, а после нажатия второй первое число делится на второе.
#include <iostream>
using namespace std;
/*Поиск суммы чисел от 1 до n с цикла while*/
void SumWhile() {
int i = 1, _sum = 0, n;
cout << "n=";
cin >> n;
while (i <= n) {
_sum += i;
i++;
}
cout << _sum << endl;
}
/*Поиск суммы чисел от 1 до n с цикла do while*/
void SumDoWhile() {
int _sum = 0, n, i = 1;
cout << "n=";
cin >> n;
do {
_sum += i;
i++;
} while (i <= n);
cout << _sum << endl;
}
/*Поиск суммы чисел от 1 до n с цикла for*/
void SumFor() {
int _sum = 0, n;
cout << "n=";
cin >> n;
for (int i = 1; i <= n; i++)
_sum += i;
cout << _sum << endl;
}
/*Вывод квадратов чисел, не превосходящих n*/
void Squares() {
int n, i = 1;
cout << "n=";
cin >> n;
while (i * i <= n) {
cout << i * i << " ";
i++;
}
cout << endl;
}
signed main()
{
/*Вызываем функции*/
SumWhile();
SumDoWhile();
SumFor();
Squares();
return 0;
}
Проезжая на лошадях по дороге, автор встречает оборванного крестьянского мальчишку, за спиной которого висит котомка с книжками. Он идёт учиться. Некрасов решает подвести школьника, но тот только смущается. Автор обращается к своему юному спутнику, хотя и не ждет от него никаких ответов. Скорее, он хочет объяснить случайному собеседнику, что старания его родителей, отдавших последние деньги на обучение сына, не пропадут даром. Некрасов рисует перед крестьянским мальчишкой достаточно идиллическую картину, которую, тем не менее, подкрепляет фактами, и пророчит незнакомцу большое будущее. Возможно, он сможет повторить путь Ломоносова, этого «архангельского мужика», который «по своей и божьей воле стал разумен и велик». Поэт призывает сельского мальчонку не робеть, так как именно знания открывают перед ним все двери. Не исключено, что его юный собеседник сможет добраться до Москвы и станет учиться в университете, чтобы впоследствии принести своей стране гораздо большую пользу, чем избалованные дворянские отпрыски, которых поэт считает холодными, тупыми и напыщенными.
Источник: https://pishi-stihi.ru/shkolnik-nekrasov.html