В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ольга1480
ольга1480
27.11.2021 07:40 •  Информатика

Написать программу в python:
последовательность состоит из целых чисел и завершается числом 0. выведите, наименьший элемент, а так же какое количество элементов этой последовательности равны ее наименьшему элементу.

подсказка: обработайте первое число перед циклом. обработайте случай пустой последовательности (пользователь сразу ввел 0). в случае пустой последовательности правильный ответ: 0 0. не забывайте изменять счетчик количества минимальных объектов при изменении минимума.

формат ввода
последовательность целых чисел, каждое число на отдельной строчки. последовательность заканчивается 0.

формат вывода
минимальный элемент и число элементов, которые равны ему. числа разделите пробелом.

Показать ответ
Ответ:
nicoguy
nicoguy
14.03.2022 05:38

1)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
 
int main()
{
    char s[20];

    cout << "What is your name: ";
    cin >> s;

    cout << "Hello, " << s << endl;
 
   return 0;
}

 

2)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[100];

    cout << "Enter the string: ";
    cin.getline(s, 100);

    for(int i = strlen(s) - 1; i >= 0; i--)
    {
        cout << s[i];
    }
    cout << endl;
 
   return 0;
}

 

3)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[20];
    bool x = true;

    cout << "Enter the word: ";
    cin.getline(s, 100);

    for(int i = 0, j = strlen(s) - 1; i <= j; i++, j--)
    {
        if(s[i] != s[j])
        {
            x = false;

            break;
        }
    }

    if(x)
    {
        cout << "Palindrome" << endl;
    }
    else
        cout << "Not palindrome" << endl;
 
   return 0;
}

 

4)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[100];
    char n;

    cout << "Enter the string: ";
    cin.getline(s, 100);

    for(int i = 0; i < strlen(s); i++)
    {
        if(s[i] == 'a')
        {
            n = 'a';

            break;
        }
        else if(s[i] == 'o')
        {
            n = 'o';

            break;
        }
    }

    if(n == 'a')
    {
        cout << "\nThe first letter of A" << endl;
    }
    else if(n == 'o')
    {
        cout << "\nThe first letter of O" << endl;
    }
    else
        cout << "These letters are not available" << endl;
 
   return 0;
}


1)написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)написать программу
0,0(0 оценок)
Ответ:
Roost11
Roost11
27.05.2022 11:07

/*Решение с обобщения формула Брахмагупты для произвольного четырехугольника. Функция perimeter(double x[], double y[]) возвращает значение периметра, функция area(double x[], double y[]) возвращает значение площади, пример использования и реализация приведены ниже. */

#include <iostream>

#include <math.h>

double perimeter(double x[], double y[]);

double area(double x[], double y[]);

int main()

{

   double x[4], y[4];

   std::cout << "Quadrangle ABCD\n";

   for (auto i = 0; i < 4; i++)

   {

       std::cout << "Input coordinates of point " << char(i + 'A') << ": ";

       std::cin >> x[i] >> y[i];

   }

   std::cout << perimeter(x, y) << " " << area(x, y);

   

   return 0;

}

double perimeter(double x[], double y[])

{

   double a[4], p = 0;

   for (auto i = 0; i < 4; i++)

   {

       a[i] = sqrt((x[i]-x[(i + 1) % 4]) * (x[i]-x[(i + 1) % 4]) + (y[i]-y[(i + 1) % 4]) * (y[i]-y[(i + 1) % 4]));

       p += a[i];

   }

   return p;

}

double area(double x[], double y[])

{

   double a[4], p = 0, s = 1, d[2];

   for (auto i = 0; i < 4; i++)

   {

       a[i] = sqrt((x[i]-x[(i + 1) % 4]) * (x[i]-x[(i + 1) % 4]) + (y[i]-y[(i + 1) % 4]) * (y[i]-y[(i + 1) % 4]));

       p += a[i];

   }

   for (auto i = 0; i < 4; i++)

   {

       s *= (p / 2- a[i]);

   }

   for (auto i = 0; i < 2; i++)

   {

       d[i] = sqrt((x[i]-x[i + 2]) * (x[i]-x[i + 2]) + (y[i]-y[i + 2]) * (y[i]-y[i + 2]));

   }

   s -= (a[0] * a[2] + a[1] * a[3] + d[0] * d[1]) * (a[0] * a[2] + a[1] * a[3] - d[0] * d[1]) / 4;

   s = sqrt(s);

   return s;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота