В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Nad17ka
Nad17ka
20.10.2022 15:14 •  Информатика

Написать программу в Python
Напишите программу, которая печатает названия месяцев до месяца n (n натуральное, вводится с клавиатуры) согласно шаблону, представленному в примере. Если n > 12, программа должна вывести "Error".

Sample Input:

4

Sample Output:

Первый месяц - январь

Второй месяц - февраль

Третий месяц - март

Четвертый месяц - апрель

Показать ответ
Ответ:
radich16
radich16
13.03.2020 13:34
Задание 1
Информационный объем I = 44100 Гц * 5 * 60 с * 16 бит = 211680000 бит = 26460000 байт = 25839,84375 Кбайт = 25,23422241210938 Мбайт

Задание 2
I = 1,3 Мбайт t = 1 мин Частота дискретизации v = 1,3 * 1024 * 1024 * 8 бит / 60 с / 8 бит = 22719,147 Гц

Задание 3
I = 5.1 Мбайт, t = 2 минуты, v = 22050 Гц Разрядность аудиоадаптера i = 5.1 * 1024 * 1024 * 8 бит / (2 * 60) с / 22050 Гц = 16,1685 бит (округленно 16 бит)

Задание 4
I = 0.01 Гбайт, i = 16 бит, v = 44100 Гц Время t = 0,01 * 1024 * 1024 * 1024 * 8 бит / 16 бит / 44100 Гц = 121 с (округляем до 120 с)
0,0(0 оценок)
Ответ:
//Я просто опишу метод записи матрицы
const n=100;
var ar:array of array of integer;
 ars:array of array of string;
 i:integer;
 
procedure complection(var ar:array of array of integer;var ars:array of array of string);
var
 i,j:integer;
begin;
for i:=1 to n do
 begin;
   for j:=1 to n do
    begin;
     ar[i,j]:=random(9);
     str(ar[i,j],ars[i,j]);
    end;
 end;
end;

procedure burning(ars:array of array of string);
var
 i,j:integer;
 t:text;
 begin;
  assign(t,'text.txt');
  rewrite(t);
  for i:=1 to n do
   begin;
    writeln(t,' ');
     for j:=1 to n do
      write(t,ars[i,j],' ');
   end;
 end;  

begin;
randomize;
setlength(ar,n+1);
setlength(ars,n+1);
for i:=1 to n do
 begin;
  setlength(ar[i],n+1);
  setlength(ars[i],n+1);
 end;
complection(ar,ars);
burning(ars);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота