В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vitakotov009
vitakotov009
01.04.2023 21:48 •  Информатика

Написать программу в питоне Напишите программу вычисления функции y(x)для всех различных вариантов входных параметров. Ввести с клавиатуры x, вывести значения функции для всех вариантов.


Написать программу в питоне Напишите программу вычисления функции y(x)для всех различных вариантов в

Показать ответ
Ответ:
anton20063
anton20063
15.01.2021 21:25

#include <iostream>

#include <cmath>

using namespace std;

signed main()

{

   setlocale(LC_ALL, "Rus");

   int N;

   bool haveZero = false, haveOne = false;

   cin >> N;

   N = abs(N);

   while(N>0){

       if(N % 10 == 0)

           haveZero = true;

       if(N % 10 == 1)

           haveOne = true;

       N /= 10;

   }

   cout << "Наличие нуля: " << boolalpha << haveZero << endl;

   cout << "Наличие единицы в числе: " << boolalpha << haveOne << endl;

   return 0;

}

0,0(0 оценок)
Ответ:
nexorosheva06
nexorosheva06
17.08.2022 03:13

Программа написана на языке C# (.NET Framework)

- Если число должно выдаваться пользователем:

using System;

namespace ConsoleApp2

{

class Program

{

static void Main(string[] args)

{

while (true)

{

int o = Int32.Parse(Console.ReadLine());

if (o < 100 || o > 999)

{

Console.WriteLine("Ошибка!");

Console.ReadLine();

}

else

{

int a = o / 100,

b = (o / 10) % 10,

c = o % 10;

String x = Convert.ToString(b) + Convert.ToString(a) + Convert.ToString(c);

Console.WriteLine(x);

Console.ReadLine();

}

}

}

}

}

- Если число должно выдаваться с запуском программы:

using System;

namespace ConsoleApp2

{

class Program

{

static void Main(string[] args)

{

while (true)

{

Random rnd = new Random();

int o = rnd.Next(100, 999),

a = o / 100,

b = (o / 10) % 10,

c = o % 10;

String x = Convert.ToString(b) + Convert.ToString(a) + Convert.ToString(c);

Console.WriteLine(o);

Console.WriteLine(x);

Console.ReadLine();

}

}

}

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота