написать программу в паскале. Вводятся координаты 5 различных (все координаты различны) точек на плоскости, через первые 3 проходит окружность (в частном случае прямая) через 2 оставшихся прямая. Вывести расстояние от окружности до прямой, если они не пересекаются и сообщение, что пересекаются в противном случае.
//Pascal ABC.NET 3.1 сборка 1256
Const
n=10;
Var
ar:array[1..n] of integer;
i,max,min:integer;
b:boolean;
begin
randomize;
b:=false;
max:=integer.MinValue;
min:=integer.MaxValue;
writeln('Array:');
for i:=1 to n do
begin
ar[i]:=random(-100,100);
if (ar[i]>max) and not(odd(ar[i])) and (ar[i]>0) then
begin
max:=ar[i];
b:=true;
end;
if (ar[i]<min) and not(odd(ar[i])) and (ar[i]>0) then
begin
min:=ar[i];
b:=true;
end;
write(ar[i]:4);
end;
writeln;
if b=false then writeln('Нет удовлетворяющих условиям чисел') else
begin
writeln('Max=',max);
writeln('Min=',min);
end;
end.
Пример работы программы:
Array:
98 60 -41 -88 63 -81 -77 -96 -18 51
Max=98
Min=60
begin
case ReadInteger('Номер месяца (1-12):') of
1,2,12:Writeln('Зима');
3..5:Writeln('Весна');
6..8:Writeln('Лето');
9..11:Writeln('Осень');
else Writeln('Неверный номер месяца')
end
end.
Вариант "для школьников"
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
var n:integer;
begin
Write('Номер месяца (1-12): '); Read(n);
case n of
1,2,12:Writeln('Зима');
3..5:Writeln('Весна');
6..8:Writeln('Лето');
9..11:Writeln('Осень');
else Writeln('Неверный номер месяца')
end
end.