В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу в паскале. удалить из строки все четырехбуквенные слова.

Показать ответ
Ответ:
aminkaaverynova
aminkaaverynova
23.09.2020 18:29
//PascalABC.NET 3.1 сборка 1200
const
  wordl = 4;

begin
  var s := ReadlnString('s = ');
  var s1 := '';
  var i := 1;
 
  repeat
    var t := pos(' ', s, i + 1);
    
    if ((s[i] = ' ') or (i = 1))
      and (((t = 0) and (Length(s) - i = wordl)) or (t - i - 1 = wordl))
      then
      i := i + wordl + 1
    else begin
      s1 := s1 + s[i];
      i := i + 1;
    end;
  until i > length(s);
 
  writeln(s1)
end.
0,0(0 оценок)
Ответ:
Djamila1108
Djamila1108
23.09.2020 18:29
Var 
 S: string; 
 i, k: integer; 
 b: boolean;
begin 
 readln(s); 
 var n := Length(s); 
 i := 1; 
 repeat   
  b := true;   
  while (i <= n) and (s[i] <> ' ') do
   begin    
     if b then
        begin        
           k := i;        
           b := false      
    end;     
   inc(i)   
 end;   
 if i - k = 4 then
  begin      
    delete(s, k, 5);      
    i := k;      
    n := n - 5   
   end    
  else inc(i) 
  until i > n; 
  write(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота