Написать программу в Паскале по этой задаче. Задача: «В конус, радиус основания которого R и высота H, требуется вписать цилиндр, имеющий наибольшую площадь полной поверхности. Найдите радиус цилиндра.» Очень надо!
Запишем таблицу распределения мест по купе: Купе Места 1 1-4,53,54 2 5-8,51,52 3 9-12,49,50 4 13-16,47,48 5 17-20,45,46 6 21-24,43,44 7 25-28,41,42 8 29-32,39,40 9 33-36,37,38 Установим связь номера места с номером купе. Предлагается следующий (конечно же, не единственный) вариант:
Здесь знаком ÷ обозначена операция целочисленного деления.
Теперь можно написать программу. Язык программирования в задании не указан, поэтому выбран язык свободно распространяемой для целей обучения системы программирования PascalABC.Net
var n:integer; begin Write('Укажите номер места: '); Read(n); Write('Место располагается в купе №'); if n<=36 then Write((n-1) div 4 + 1) else Write((54-n) div 2 + 1) end.
Тестовое решение: Укажите номер места: 18 Место располагается в купе №5
Факультет географии и природопользования КазНУ им. аль-Фараби был открыт в 1948 г. Тогда он имел название геолого-географический и был представлен двумя отделениями – геологическим и географическим. В связи с закрытием геологического отделения в 1960 году факультет был переименован в географический. Сегодня факультет отвечает самым высоким требованиям и международным стандартам. За время своего существования факультет подготовил более 5 тыс. специалистов географического профиля: географов, метеорологов, гидрологов, экологов, картографов, менеджеров туризма и др.
У истоков факультета стояли выдающиеся ученые-географы, внесшие большой вклад в развитие географической науки в Казахстане. Среди них назовем проф. В.А.Соколова, проф. М.Ж.Жандаева, проф. Г.Г.Муравлева, доц. З.П.Коженкову, проф. В.И.Коровина, проф. А.В.Чигаркина и др. Большой вклад в становление географического факультета внес на посту ректора КазНУ академик У.А. Джолдасбеков.
Купе Места
1 1-4,53,54
2 5-8,51,52
3 9-12,49,50
4 13-16,47,48
5 17-20,45,46
6 21-24,43,44
7 25-28,41,42
8 29-32,39,40
9 33-36,37,38
Установим связь номера места с номером купе. Предлагается следующий (конечно же, не единственный) вариант:
Здесь знаком ÷ обозначена операция целочисленного деления.
Теперь можно написать программу. Язык программирования в задании не указан, поэтому выбран язык свободно распространяемой для целей обучения системы программирования PascalABC.Net
var
n:integer;
begin
Write('Укажите номер места: '); Read(n);
Write('Место располагается в купе №');
if n<=36 then Write((n-1) div 4 + 1)
else Write((54-n) div 2 + 1)
end.
Тестовое решение:
Укажите номер места: 18
Место располагается в купе №5
Факультет географии и природопользования КазНУ им. аль-Фараби был открыт в 1948 г. Тогда он имел название геолого-географический и был представлен двумя отделениями – геологическим и географическим. В связи с закрытием геологического отделения в 1960 году факультет был переименован в географический. Сегодня факультет отвечает самым высоким требованиям и международным стандартам. За время своего существования факультет подготовил более 5 тыс. специалистов географического профиля: географов, метеорологов, гидрологов, экологов, картографов, менеджеров туризма и др.
У истоков факультета стояли выдающиеся ученые-географы, внесшие большой вклад в развитие географической науки в Казахстане. Среди них назовем проф. В.А.Соколова, проф. М.Ж.Жандаева, проф. Г.Г.Муравлева, доц. З.П.Коженкову, проф. В.И.Коровина, проф. А.В.Чигаркина и др. Большой вклад в становление географического факультета внес на посту ректора КазНУ академик У.А. Джолдасбеков.