В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
luluik
luluik
03.12.2021 22:27 •  Информатика

Написать программу в паскале, которая проверяет, есть ли во введенном с клавиатуры массиве элементы с одинаковым значением.

Показать ответ
Ответ:
graf2231
graf2231
10.06.2020 19:17

var a:array [1..100] of integer;

n,i,j:integer;

f:boolean;

BEGIN

  read(n);

  f:=false;

  for i := 1 to n do begin

    readln(a[i]);

    for j:= 1 to i-1 do

      f=f or (a[i]=a[j]);

  end;

  writeln(f);

 

END.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота