В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
алина3759
алина3759
17.05.2022 23:04 •  Информатика

Написать программу в паскале, которая формирует матрицу nXn в следующем виде: У меня есть программа, которая формирует матрицу в виде:
1 1 1 1 1 1 1 1 1 1
2 2 2 2 2 2 2 2 2 1
3 3 3 3 3 3 3 3 2 1
4 4 4 4 4 4 4 3 2 1
5 5 5 5 5 5 4 3 2 1
6 6 6 6 6 5 4 3 2 1
7 7 7 7 6 5 4 3 2 1
8 8 8 7 6 5 4 3 2 1
9 9 8 7 6 5 4 3 2 1
10 9 8 7 6 5 4 3 2 1
И программа для нее:
var
n,i,j: integer;
a: array[1..20,1..20] of integer;
begin
write('Введите размерность матрицы');
readln(n);
for i:=1 to n do
begin
for j:=1 to n do
begin
if i+j a[i,j]:=n-j+1;
write(a[i,j]:4);
end;
writeln;
end;
end.


Написать программу в паскале, которая формирует матрицу nXn в следующем виде: У меня есть программа,

Показать ответ
Ответ:
maximunicorn1
maximunicorn1
04.11.2020 14:00

1

1

1

1

1

2

3

4

5

6

End end endend

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота