В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
жак77777
жак77777
05.03.2023 17:58 •  Информатика

Написать программу в паскале " для заданной квадратной матрицы 6*6 сформировать одномерный массив из ее диагональных элементов. вывести исходный массив и результаты вычисления."

Показать ответ
Ответ:
DianaTesl
DianaTesl
02.10.2020 15:32
Const
n=6;
var
a:array[1..n,1..n]of integer;
b:array[1..n]of integer;
i,j:integer;
begin
   for i:=1 to n do
        begin
            for j:=1 to n do
                begin
                    a[i,j]:=random(100);
                    write(a[i,j]:4);  
                 end;
             b[i]:=a[i,i];
             writeln;
         end;
writeln;
for i:=1 to n do
    write(b[i]:4);
end.
вариант главной и побочной диагонали в одномерный массив
const
n=6;
var
a:array[1..n,1..n]of integer;
b:array[1..n*2]of integer;
i,j,k:integer;
   begin
       writeln;   
           for i:=1 to n do       
              begin           
                for j:=1 to n do               
                    begin                   
                        a[i,j]:=random(100);                   
                         write(a[i,j]:4);               
                    end;               
                      k:=k+1;             
                      b[k]:=a[i,i];             
                      k:=k+1;           
                       b[k]:=a[i,n+1-i];           
                  writeln;         
                 end;
writeln;
   for i:=1 to n*2 do 
          write(b[i]:4);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота