Написать программу в паскале: даны целое n> 0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. найти величину наибольшего среди отрицательных чисел этой последовательности.
Var x,max:real; n,i:integer; begin write('Введите число n: '); readln(n); for i:=1 to n do begin write('Введите число ',i,': '); readln(x); if x<0 then begin if max=0 then max:=x; // если это первое отр.число if x>max then max:=x end end; writeln('Наибольшее среди отрицательных: ',max) end.
x,max:real;
n,i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=1 to n do
begin
write('Введите число ',i,': ');
readln(x);
if x<0 then
begin
if max=0 then max:=x; // если это первое отр.число
if x>max then max:=x
end
end;
writeln('Наибольшее среди отрицательных: ',max)
end.