Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
korablevabella
10.04.2020 11:29 •
Информатика
Написать программу в паскале. дано произвольное целое положительное число k. найти сумму всех чётных цифр этого числа
Показать ответ
Ответ:
регинамаг
12.07.2020 01:56
Program folsc;
uses crt;
var s, n:longint;
begin
s:=0;
read (n);
while (n <> 0) do begin
if ((n mod 10) mod 2) =0 then s:=s+n mod 10;
n:=n div 10 end;
writeln (s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
tomakor
14.05.2022 04:44
Всем здравствуйте решить задачу по информатике , что на картинке....
gagag590
27.12.2022 13:53
Яких значень має набувати лічильник циклу...
KONERtm
06.01.2020 22:46
1. Дополни предложения, в окошки напиши (скопируй) недостающие слова: (шрифт, алфавитном порядке, специальные окошки, кнопки изменения стиля, pt, дюйма, названия шрифтов,...
Anhelodek
16.05.2022 11:48
Очень надо! Только правильно отвечайте ...
Агааемгов
10.01.2021 08:21
Напишите программу на Python 10.11 Создайте матрицу (список из вложенных списков) размера N x N (фиксируются в программе), заполненную случайными целыми числами...
Staer1188
08.01.2020 02:35
Составить программу паскаль, которая находит сумму членов арифмитической прогрессии, если известны ее первый член, разность и число членов арифмитической прогрессии...
Annsad12121
19.03.2022 12:14
Массив состоит из 20 целых чисел от 0 до 10. найти в массиве те элементы, значение которых меньше среднего арифметического, взятого от всех элементов массива и вывести...
МировойПельмень
19.03.2022 12:14
Какие существуют форматы текстовых файлов и чем они отличаются друг от друга...
itsnastyad
11.12.2020 15:17
Определи значение переменной a после выполнения фрагмента алгоритма при a=5 и a=18. ввод а если a 5 то a: =a+20 иначе a: =a*10 всё ответ: при a=5 значение переменной...
FD140
16.11.2022 20:48
Даны три целых числа: a, b, c. проверить истинность высказывания: «хотя бы одно из чисел a, b, c положительное» с++...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
uses crt;
var s, n:longint;
begin
s:=0;
read (n);
while (n <> 0) do begin
if ((n mod 10) mod 2) =0 then s:=s+n mod 10;
n:=n div 10 end;
writeln (s);
end.