В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
DuginBorodaIzVaty
DuginBorodaIzVaty
16.09.2020 12:17 •  Информатика

Написать программу в паскале. дано натуральное семизначное число р. вывести на экран цифры чила, которые делятся на а без остатка. определить кол-во цифр, удовлетворяющих этому условию.

Показать ответ
Ответ:
tanya732
tanya732
01.09.2020 06:57
// PascalABC.NET 3.2, сборка 1467 от 02.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Write('Введите Р и а: ');
  var (P,a):=ReadInteger2;
  var k:=0;
  while P>0 do begin
    var d:=P mod 10;
    if d mod a=0 then begin Print(d); k+=1 end;
    P:=P div 10
    end;
  Writeln(Newline,'Искомых чисел: ',k)
end.

Пример
Введите Р и а: 7568450 5
0 5 5
Искомых чисел: 3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота