В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
egorikmail826
egorikmail826
02.10.2021 05:54 •  Информатика

Написать программу в паскале, чтобы на выходе получть: сколько раз за февраль температура была> 0, первую дату , когда она повысилась> 0, количество дней, когда температура отличалась от средней не более чем на 1 (температура вводится рандомно)

Показать ответ
Ответ:
Onewood
Onewood
22.08.2021 09:05

{данная программа переводит любое сочетание символов ascii в систему счисления заданную пользователем.}

//pascal abc.net v3.0 сборка 1111

var

  a,i,b,r,n,j,bug: integer;

  s,se,slo,slof: string;

procedure preob(var a,b,n: integer; var se: string);

  begin

  repeat

    b: =a mod n;

    a: =a div n;

    str(b,se);

    s+=se;

  until (a< =n-1);

  end;

beginreadln(slo);

readln(n);

for j: =1 to length(slo) do

begin;

a: =ord(slo[j]);

preob(a,b,n,se);

str(a,se);

s+=se;

for i: =1 to length(s) div 2 do

begin;

se: =s[i];

s[i]: =s[length(s)-i+1];

s[length(s)-i+1]: =se[1];

end;

write(s,'-');

slof: =slof+s;

delete(s,1,length(s));

end;

end.

пример ввода:

работа на завтра.

2

пример вывода:

11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-

{таким образом, фразу " работа на завтра." можно закодировать как "11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-".}

0,0(0 оценок)
Ответ:
1POMOGUTE1
1POMOGUTE1
02.04.2021 12:54

program Geom;

program Test_nn;

{$APPTYPE CONSOLE}

{$R *.res}

uses

 Math;

var

 a: array of Extended;

 n, i, c: Integer;

 x: Extended;

begin

 Write ('Размерность массива = ');

 ReadLn (n);

 SetLength (a, n);

 Randomize;

 for i := Low (a) to High (a) do begin

   a [i] := (Random (2001) - 1000) / 1000;

   Write (a [i] :7 :3);

 end;

 x := 1;

 c := 1;

 WriteLn;

 for i := Low (a) to High (a) do begin

   if a [i] > 0 then begin

     Write (a [i] :7 :3);

     x := x * a [i];

     Inc (c);

   end;

 end;

 WriteLn;

 WriteLn ('Среднее геометрическое = ', Power (x, 1/c) :20 :15);

 ReadLn;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота