Написать программу в паскаль : в массиве из 10 вводимых с клавиатуры чисел подсчитать количество чисел кратных первому элементу, но не кратных последнему элементу
Var a,b,c,i,sum,cp:integer; begin sum:=0; cp:=0; Randomize; writeln('Посчитайте сложение:'); while i<10 do begin a:=random(40)+10; b:=random(60)+10; sum:=a+b; write('Сколько будет ',a,'+',b,'= '); read(c); if c=sum then begin cp:=cp+1; writeln('Молодец!'); end else writeln('Неправильно'); i:=i+1; end; writeln('Всего правильных ответов ',cp); write('Оценка:'); if (cp<=4) then write('Очень плохо (2)') else if (cp>=5) and (cp<=6) then write('Удовлетворительно (3)') else if (cp>=7) and (cp<=8) then write('Хорошо (4)') else if (cp>=9) then write('Отлично! (5)'); end.
Попробуем сделать сортировку букв латинского алфавита.
const n = 20; var a: array[1..n] of char; i, j: integer; t: char;
begin Randomize; Writeln('Исходный массив'); for i := 1 to n do begin a[i] := Chr(random(26)+Ord('A')); Write(a[i],' ') end; Writeln; for i := 1 to n-1 do for j := 1 to n-i do if a[j] > a[j+1] then begin t := a[j]; a[j] := a[j+1]; a[j+1] := t end; Writeln('Отсортированный по возрастанию массив'); for i := 1 to n do Write(a[i],' '); Writeln end.
Тестовое решение: Исходный массив G Z L H X A R E C F G X O T C L N U D L Отсортированный по возрастанию массив A C C D E F G G H L L L N O R T U X X Z
begin
sum:=0;
cp:=0;
Randomize;
writeln('Посчитайте сложение:');
while i<10 do
begin
a:=random(40)+10;
b:=random(60)+10;
sum:=a+b;
write('Сколько будет ',a,'+',b,'= ');
read(c);
if c=sum then begin
cp:=cp+1;
writeln('Молодец!');
end else writeln('Неправильно');
i:=i+1;
end;
writeln('Всего правильных ответов ',cp);
write('Оценка:');
if (cp<=4) then write('Очень плохо (2)') else
if (cp>=5) and (cp<=6) then write('Удовлетворительно (3)') else
if (cp>=7) and (cp<=8) then write('Хорошо (4)') else
if (cp>=9) then write('Отлично! (5)');
end.
const
n = 20;
var
a: array[1..n] of char;
i, j: integer;
t: char;
begin
Randomize;
Writeln('Исходный массив');
for i := 1 to n do
begin
a[i] := Chr(random(26)+Ord('A'));
Write(a[i],' ')
end;
Writeln;
for i := 1 to n-1 do
for j := 1 to n-i do
if a[j] > a[j+1] then
begin t := a[j]; a[j] := a[j+1]; a[j+1] := t end;
Writeln('Отсортированный по возрастанию массив');
for i := 1 to n do Write(a[i],' ');
Writeln
end.
Тестовое решение:
Исходный массив
G Z L H X A R E C F G X O T C L N U D L
Отсортированный по возрастанию массив
A C C D E F G G H L L L N O R T U X X Z