В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vik1767
Vik1767
10.06.2020 15:51 •  Информатика

Написать программу в паскаль, которая вычисляет корни уравнения y=4х2-7/квадратный корень 6х+8, ввод данных с клавиатуры.

Показать ответ
Ответ:
алина3734
алина3734
24.10.2021 14:05
# 1

list = []

while True:

   n = int(input("nb: "))

   if n == 0:

       break

   list.append(n)

res = 1

sum = sum(list)

for x in list:

   if x * x > sum:

       res *= x

print(res)

# 2

def isPerfectSquare(num):

   s = int(num**0.5)

   return s * s == num

def isFibonacciNumber(n):

   return isPerfectSquare(5 * n * n + 4) or isPerfectSquare(5 * n * n - 4)

list = []

while True:

   n = int(input('nb : '))

   if n % 2:

       odd = n

       break

   list.append(n)

if isFibonacciNumber(n):

   print([x for x in list if not(x % 3)])

else:

   print([x for x in list if not(x % 5)])

# 3

list = []

N = int(input('N = '))

for i in range(N):

   n = int(input('nb : '))

   list.append(n)

print(sum([x for x in list if x * x % 10 == 9]))


Решить 3 и 1\2 задачу ) Написать программы на языке программирования Python: 1) С клавиатуры вводятс
Решить 3 и 1\2 задачу ) Написать программы на языке программирования Python: 1) С клавиатуры вводятс
Решить 3 и 1\2 задачу ) Написать программы на языке программирования Python: 1) С клавиатуры вводятс
0,0(0 оценок)
Ответ:
karisafedotova2
karisafedotova2
11.08.2021 09:51

class Program

 {

   static void Main(string[] args)

   {

     string src = " Qwy. ... Asdf.. Lkjdfs A.";

     //string dest = ReplaceDots(src, '.', '…', 3);

     string dest = ReplaceDots(src, '.', "...", 3);

 

     Console.WriteLine("src:\t" + src);

     Console.WriteLine("dest:\t" + dest);

 

     Console.WriteLine();

     Console.Write("Press any key for exit ...");

     Console.ReadKey(true);

   }

 

   //private static string ReplaceDots(string src, char dotCh, char dots, int minDotsCount)

   private static string ReplaceDots(string src, char dotCh, string dots, int minDotsCount)

   {

     StringBuilder dest = new StringBuilder();

 

     int i = 0;

     while (i < src.Length)

     {

       int dotsCount = 0;

       while (i < src.Length && src[i] == dotCh)

       {

         dotsCount++;

         i++;

       }

 

       if (dotsCount >= minDotsCount)

         dest.Append(dots);

       else if (dotsCount == 0)

         dest.Append(src[i++]);

       else

         while (dotsCount-- > 0)

           dest.Append(dotCh);

     }

 

     return dest.ToString(); ;

   }

 }

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота