В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kotovich9292
kotovich9292
21.04.2020 04:37 •  Информатика

Написать программу в pascalabc.net задано натуральное число .напишите программу ,которая для число с нечётным количеством цифр выведет на экран цифру , стоящую на средней позиции числа .

Показать ответ
Ответ:
кристина2164
кристина2164
07.06.2020 00:05

var

 x, a, k, t, i, d: integer;

begin

 readln(x);

 a := x; k := 0;

 while a > 0 do

 begin

   k += 1;

   a := a div 10;

 end;

 if k mod 2 = 0 then

   write('В числе четное количество цифр')

 else

 begin

   t := 1;

   for i:=1 to k div 2 do

     t *= 10;

   d := x div t mod 10;

   write(d);

 end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота