Написать программу в PASCAL (желательно с легкими формулами и значениями) : Известно количество грузовиков (6), их грузоподъемность (615 у каждого). Необходимо определить, сколько грузов и какой массы можно вывезти за 1 раз, если в 1 очередь надо погрузить груз, масса которого находится между 220-230 кг
не так уж и трудно, если
program project2;
var
n,a,b,c,i,k,max,min: longint;
inp,outp: text;
begin
assign(inp,'input.txt');
reset(inp);
assign(outp,'output.txt');
rewrite(outp);
readln(inp,n);
max: =0;
min: =0;
c: =0;
for i: =1 to n do
begin
read(f1,a);
if i=1 then
b: =a;
if a> max then
max: =a;
k: =a-c;
c: =a;
if k< 0 then
begin
k: =abs(k);
min: =min+k;
if k> min then
min: =k;
end;
end;
max: =max-b;
write(outp,max,' ',min);
close(inp);
close(outp);
end.
В непосредственном режиме- видимо без ввода программы, ввести последовательно строки (сначала присваиваем значение переменной икс, затем вычисляем выражение и помещаем это значение в переменную игрек, и после печатаем значение переменной игрек):
LET X=1.12
LET Y=SQR (X^3+EXP X-LN (3*X))*(1+4*SIN (X/2)+5*EXP (SIN X))
PRINT Y
И записать результат вычислений, который высветится на экране (у меня получилось 27.839525 но у вас может немного отличаться).
Надеюсь, что в вашей версии бейсика нет отличий от той, что у меня (она весьма старая).