В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mrprogemir
mrprogemir
24.09.2020 19:31 •  Информатика

Написать программу в pascal даны целые числа . если в данной последовательности ни одно четное число не расположено после нечетного.то получить все отрицательные члены последовательности иначе-положительное.

Показать ответ
Ответ:
innapuna8
innapuna8
24.05.2020 00:41

var
a: array[1..50] of integer;
i,f, n: integer;

begin
write('n=');
readln(n);
for i := 1 to n do
begin
write('a', i, '=');
readln(a[i]);
end;
f := 0;
writeln;
for i := 1 to n - 1 do
if (a[i] mod 2 <> 0) and (a[i + 1] mod 2 = 0) then f := 1;
if f = 0 then
begin
for i := 1 to n do
if a[i] < 0 then write(a[i]:4);
end
else
for i := 1 to n do
if a[i] > 0 then write(a[i]:4);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота