В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ivanivankuznets
ivanivankuznets
03.06.2023 15:28 •  Информатика

Написать программу в pascal abc для нахождения наибольшего общего делителя произвольных десяти целых двухзначных чисел с алгоритма евклиада(procedure).

Показать ответ
Ответ:
fheeubeujdshebj
fheeubeujdshebj
07.09.2020 10:37
// PascalABC.NET 3.0, сборка 1110
procedure Euclid(a,b:integer; var gcd:integer);
var
  t:integer;
begin
  while b<>0 do begin
    a:=a mod b;
    t:=b; b:=a; a:=t
    end;
  gcd:=a
end;

var
  i,a,b,c:integer;
begin
  Randomize;
  for i:=1 to 10 do begin
    a:=Random(99)+1;
    b:=Random(99)+1;
    Euclid(a,b,c);
    Writeln('НОД(',a,',',b,')=',c)
    end
end.

Тестовое решение:
НОД(32,68)=4
НОД(80,68)=4
НОД(36,19)=1
НОД(4,61)=1
НОД(46,72)=2
НОД(55,53)=1
НОД(75,76)=1
НОД(27,96)=3
НОД(98,82)=2
НОД(46,23)=23
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота