В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
inkara8
inkara8
26.02.2023 16:43 •  Информатика

Написать программу в любой программе(лучше всего на сишарп), которая преобразует целое положительное десятичное число (число разрядов не более 6) в его эквивалент в 2 систему счисления. программа должна вводить число в 10 систему счисления и печатать результат в 2 системе счисления. например: введите целое число в 10c/c: 12 двоичный эквивалент равен 1100 незначащие нули должны подавляться. должен быть контроль вводимых цифр. разрешены цифры 0 - 9.

Показать ответ
Ответ:
maloy4424
maloy4424
06.10.2020 11:32
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

function Dec2Bin(x:string):string;
begin
  var s:=x.MatchValue('\d+');
  if s.Length=0 then begin
    Writeln('Не найдено НИ ОДНОЙ цифры!');
    Result:=''
    end
  else begin
    var t:=s.ToInteger;
    var r:string:='';
    while t>=2 do (r,t):=(t mod 2+r,t shr 1);
    Result:=t+r
    end
end;

begin
  Writeln(Dec2Bin(ReadlnString('n=')))
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота