В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
latifa5
latifa5
09.10.2022 03:53 •  Информатика

написать программу в кумире:
Заполните таблицу размерности N неповторяющимися целыми случайными числами из интервала от 1 до N. Вывести полученную таблицу на экран. Определите среднее арифметическое элементов полученной таблицы.
Пример выполнения:
алг среднее_арифметическое_элементов_таблицы
нач
цел N
вещ rez
лог error
вывод "Кол-во случайных чисел=>>"
ввод N
error:=(N<1)
если error
то вывод "Таблицу создать невозможно"
выход
все
цел таб A[1:N]
InputTable(N,A)
вывод "Заполненная таблица:",нс
OutputTable(N,A)
rez:=Average(N,A)
вывод "Среднее арифметическое элементов таблицы:",rez
кон
алг вещ Average(цел size, цел таб Table[1:size]) нач
цел S, i
S:=0
нц для i от 1 до size
S:=S+Table[i]
кц
знач:=S/size
кон
алг InputTable(арг цел size, рез цел таб Table[1:size])
нач
цел i
нц для i от 1 до size
Table[i]:= irand(1,size)
кц
кон
алг OutputTable(цел size, цел таб Table[1:size])
нач
цел i
лог error
error:=(size<1)
если error
то вывод "Таблица не содержит элементов"
выход
все
нц для i от 1 до size
вывод i,"-й : ", Table[i]
если i=size
то вывод "."
иначе вывод "; "
все
вывод нс
кц
вывод нс
кон

Показать ответ
Ответ:
ДаняКашин
ДаняКашин
22.08.2022 13:26

ЯП: С++ | можно не писать std:: , если использовать пространство имен: using namespace std;

#include <iostream>

int main() {

const int SIZE = 10;

int regim, sum, max, count;

int arr[SIZE];

for (int i = 0; i < SIZE; i++)

{

 std::cin >> arr[i]; // вводим элементы массива

 std::cout << arr[i] << "\t"; // выводим массив в консоль

}

std::cin >> regim;

if ((regim > 0) && (regim < 4))

{

 if (regim == 1)

 {

  for (int i = 0; i < SIZE; i++)

  {

   sum += arr[i]; // или sum = sum + arr[i];

  }

  std::cout << "Сумма элементов массива = " << sum << std::endl;

 }

 else if (regim == 2)

 {

  max = arr[0];

  for (int i = 0; i < SIZE; i++)

  {

   if (max < arr[i])

    max = arr[i];

  }

  std::cout << "Максимальный элемент в массиве = " << max << std::endl;

 }

 else

 {

  for (int i = 0; i < SIZE; i++)

  {

   if (arr[i] < 0)

    count++;

  }

  std::cout << "Число отрицательных элементов в массиве = " << count << std::endl;

 }

}

else

 std::cout << "Доступен только 1-3 режим!" << std::endl;

return 0;

}

0,0(0 оценок)
Ответ:
РенаКОСЫРЕВА
РенаКОСЫРЕВА
22.08.2022 13:26

#include <iostream>

using namespace std;

int main() {

setlocale(LC_ALL, "");

int N = 10;

int max = -9999999;

int sum = 0;

int choise = 0;

int arr[N] = {0};

cout << "Введите 10 значений: ";

for(int i = 0; i<N; ++i) {

cin >> arr[i];

}

cout << "Введите действие (1 - +, 2 - макс. значение, 3 - колво отр. значений)";

cin >> choise;

if(choise==1) {

for(int i = 0; i<N; ++i) {

sum+=arr[i];

}

cout << endl << "Сумма: " << sum;

}

if(choise==2) {

for(int i = 0; i<N; ++i) {

if(arr[i]>max) {

max = arr[i];

}

}

 cout << endl << "Макс. знач: " << max;

}

if(choise==3) {

 for(int i = 0; i<N; ++i) {

   if(arr[i]<0) {

     ++sum;

   }

 }

 cout << "Колво отр. знач: " << sum;

}

 if(choise!=1&&choise!=2&&choise!=3) {

   cout << "Введите корректное значение.";

 }

 return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота