В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
verbenalaym
verbenalaym
08.02.2021 22:35 •  Информатика

Написать программу в которой вычисляется сумма десятков трёх целых чисел, больше 9.
например, 3 числа: 12, 234, 4563, сумма десятков (2+3+6)=11

Показать ответ
Ответ:
ginfv
ginfv
10.10.2020 23:31

#summa vtorqh elementov s konca chisel, kotorqe bolshe 9 s proverkoj na 9

a=0

b=0

c=0

print("Vvedite celqe chisla bolshe 9\n")

while int (a) < 10:

   a = input("Vvedite pervoe chislo: ")

else:

   while int (b) < 10:

       b = input("Vvedite vtoroe chislo: ")

   else:

       while int (c) < 10:

           c = input("Vvedite tretje chislo: ")

a=str(a)[::-1]  #Perevodim v stroku i reversiruem

b=str(b)[::-1]  #t.k. nachinaem sleva napravo

c=str(c)[::-1]  #i tak legche vsego najti vtoroe chislo s konca

A=int(a[1])  #perevodim obratno v int dlja provedenija matem operacij nad nimi

B=int(b[1])  #element [1] i budet vtoroe chislo s konca

C=int(c[1])

if A==1:

   A=A+1

if B==1:

   B=B+1

if C==1:

   C=C+1

sum = A+B+C

print("Summa desjatkov = " + str(sum))

Объяснение:

Это на python, наверное далеко не самый корректный код, но задачу выполняет. Если я правильно понял, то например у числа 12 десятком будет 2? (Судя по заданию)  - если это не так, то надо всего лишь удалить весь блок проверки if (от if A==1: до C=C+1)


Написать программу в которой вычисляется сумма десятков трёх целых чисел, больше 9. например, 3 числ
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота