В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
pishinaangelina
pishinaangelina
09.04.2023 21:34 •  Информатика

Написать программу в формате "паскаль", которая генерируется случайное трехзначное число и подсчитает количество цифр в нем равных 4 и 5. ! , !

Показать ответ
Ответ:
lenayun
lenayun
05.10.2020 14:52
// PascalABC.NET 3.2, сборка 1387 от 17.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  randomize;
  var s:=Random(100,999).ToString;
  Writeln('Исходное число ',s);
  var k4:=0;
  var k5:=0;
  for var i:=1 to s.Length do
  case s[i] of
  '4':k4+=1;
  '5':k5+=1
  end;
  Writeln('Четверок в числе- ',k4,', пятерок- ',k5)
end.

Пример
Исходное число 954
Четверок в числе- 1, пятерок- 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота