В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lili247
lili247
06.08.2021 23:43 •  Информатика

Написать программу в ! число в двоичной системе счисления, введенное пользователем программы, преобразовать в десятичное число.

Показать ответ
Ответ:
СуПерКотАйН
СуПерКотАйН
01.10.2020 18:04
Var a:string;
i,a1,ar:integer;b:real;
begin
readln(a);
b:=0;
for i:=1 to length(a) do 
begin 
val(a[length(a)-i+1],a1,ar);
 b:=b+a1*exp((i-1)*ln(2));
 end;
writeln('b=',b);
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота