В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
SuperLeonellus123
SuperLeonellus123
16.05.2023 23:57 •  Информатика

Написать программу в c# введите количество натуральных делителей включая 1 и само число

Показать ответ
Ответ:
mitrofanovas633
mitrofanovas633
09.10.2020 22:55

using System;

namespace DividersAmount

{

   class Program

   {

       static void Main(string[] args)

       {

           int n = int.Parse(Console.ReadLine());

           int amount = 0;

           for (int i = 1; i <= n; i++)

           {

               if (n % i == 0) amount++;

           }

           Console.WriteLine(amount);

           Console.ReadKey();

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота