В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mybrainishere11
mybrainishere11
03.05.2021 22:11 •  Информатика

написать программу в ABCPascal дано трехзначное число, найти и вывести его вторую цифру

Показать ответ
Ответ:
KristyLis
KristyLis
11.10.2020 20:03

program z1;

var a:integer;

begin

write ('Введите трехзначное число ');

readln(a);

write ('Вторая цифра числа ',a div 10 mod 10)

end.

Объяснение:

div целочичленное деление (5 div 2 = 2 ; 57 div 10 = 5)

mod остаток от целочисленного деления (5 mod 2 = 1 ; 57 mod 10 = 7)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота