Написать программу: Учет оценок. Программа должна иметь возвожность добавления ученика, предметов и оценок. Также реализовать вывод, изменение и удаление данных. Все данные хранить в текстовом файле.
Это вещественный тип данных, тоесть действительные числа, диапазон меняется в зависимости от языка, отличительная особенность этого числового типа это знаки после запятой, и даже если ввели целое число и запишется и отображаться оно будет с так называемой плавающей точкой, к примеру если ввели 5, то будет отображаться 5.0, хотя исключительно для паскаля там отображается как целая часть умноженная на 'e' в степени, и да что не самое маловажное так это - над вещественными числами можно проводить такую операцию как деление, в школьных языках программирования делить на интегер к примеру нельзя потому как может образоваться нецелое число
#include <iostream>
using namespace std;
void main ()
{
int a,b;
cin>>a>>b;
int temp;
if (a>b) {temp = b; b=a; a= temp; }
cout<< "ves' diapozon"<<endl;
for (int i = a; i<=b; i++)
{
cout<< i<<" ";
}
cout<<endl;
cout<< "chetnye"<<endl;
for (int i = a; i<=b; i++)
{
if ( (i%2)==0) cout<< i;
}
cout<<endl;
cout<< "ne chetnye"<<endl;
for (int i = a; i<=b; i++)
{
if ( (i % 2) !=0) cout<< i<<" ";
}
cout<<endl;
cout<< "krany 7"<<endl;
for (int i = a; i<=b; i++)
{
if( (i%7)==0) cout<< i;
}
system("pause");
return 0;
}
Подробнее - на -