Написать программу, тестирующую знания по астрономии. вопросов должно быть 10. вариантов ответа 3, выбор ответа однозначный. по окончании теста должно быть выведено количество правильных ответов. использовать графические модули для разработки интерфейса.
1)
var a,b,c,d:real;
begin
read(a,b);
c:=(a+b)/2;
d:=2*a*b;
if a>b then begin
a:=d;
b:=c;
end;
if a<b then begin
a:=c;
b:=d;
end;
writeln(a,' ',b);
end.
2)
var a,b:integer;
begin
read(a,b);
if (a<1) or (a>31) then writeln(' день введен неправильно');
if (b<1) or (b>12) then writeln(' месяц введен неправильно');
end.
3)
var a,b,c:real;
begin
read(a,b,c);
if (a>b)and(a>c)then writeln(a);
if (b>a)and(b>c)then writeln(b);
if (c>b)and(c>a)then writeln(c);
end.
1)
var
a,b,x,y:real;
begin
readln(a,b);
x:=(a+b)/2;
y:=2*a*b;
if a>b then
begin
a:=y;
b:=x;
end
else
begin
a:=x;
b:=y;
end;
writeln('a=',a:8:3);
writeln('b=',b:8:3);
end.
2)
var
d,m:integer;
begin
readln(d,m);
if (d<1) or (d>31) then writeln ('день введен неверно');
if (m<1) or (m>12) then writeln ('месяц введен неверно');
end.
3)
var
a,b,c:integer;
begin
readln(a,b,c);
if (a>b) and (a>c) then writeln(a);
if (b>a) and (b>c) then writeln(b);
if (c>a) and (c>b) then writeln(c);
end.