В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу, суммирующую положительные элементы массива, полученную сумму возвести в квадрат (сделать через pascal)( надо ни то 2 поставят)

Показать ответ
Ответ:
гикат
гикат
07.07.2020 12:06
Const  n = 10;  var  a :array [1..n] of integer;  i, sum :integer;
begin
  for i:= 1 to n do    readln(a[i]);    sum:= 0;  for i:= 1 to n do    if a[i] > 0 then      sum:= sum + a[i];  sum:= sqr(sum);  writeln(sum);      end.
0,0(0 оценок)
Ответ:
полина10092003
полина10092003
07.07.2020 12:06
Const N = 10;
Var i,S:integer; m:array [1..N] of integer;
Begin       
Writeln('Введите массив');       
for i:=1 to 10 do begin       
readln(m[i]);       
if m[i]>0 then S:=S+m[i]; end;       
S:=sqr(S);       
writeln('Сумма^2 равна ',S);       
readln;       
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота