В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
foreveryoung5
foreveryoung5
10.09.2022 05:47 •  Информатика

Написать программу сравнения введенного числа со значениями 0, 4,8,9 и 30. в java, с оператором switch

Показать ответ
Ответ:
VikiMikiSmile
VikiMikiSmile
10.03.2020 00:12

import datetime

now = datetime.datetime.now()

now = str(now)

now = now.replace('-', '.')

now = now[:10]

now = now[5:]

a = [['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.18'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'],['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12']]

b = []

for i in range(len(a)):

   item = a[i][3][5:]

   if item == now:

       b.append(a[i])

print('СЕГОДНЯ ДЕНЬ РОЖДЕНИЕ У:')

for j in range(len(b)):

   print(b[j][0], b[j][1], b[j][2])


Заданы данные о n=10 учащихся класса: фамилия, имя, отчество, дата рождение (год, номер месяца и чис
0,0(0 оценок)
Ответ:
medinceva24674qq
medinceva24674qq
11.03.2020 17:38

Программа:

Python:

Известны координаты вершин A, B, C треугольника. Напишите программу, вычисляющую площадь этого треугольника.

xa = int(input('xa = '))

ya = int(input('ya = '))

xb = int(input('xb = '))

yb = int(input('yb = '))

xc = int(input('xc = '))

yc = int(input('yc = '))

AB = pow((xb - xa)**2 + (yb - ya)**2, 1/2)

BC = pow((xc - xb)**2 + (yc - yb)**2, 1/2)

AC = pow((xc - xa)**2 + (yc - ya)**2, 1/2)

p = (AB + BC + AC) / 2

s = pow(p*(p - AB)*(p - BC)*(p - AC), 1/2)

print('s =', round(s))

Результат:

xa = 2

ya = 1

xb = 6

yb = 5

xc = 10

yc = 1

s = 16

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота