В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Алентина
Алентина
24.03.2023 20:33 •  Информатика

Написать программу, согласно варианту, которая определяет, попадает ли точка с заданными координатами x, y в область, закрашенную на рисунке серым цветом. Координаты должны x и y вводиться с клавиатуры, ответ выводиться на экран. на использование условного оператора if
PASCAL


Написать программу, согласно варианту, которая определяет, попадает ли точка с заданными координата

Показать ответ
Ответ:
23200611
23200611
15.08.2021 08:27

Информационное пространство представляет собой совокупность объектов, вступающих друг с другом в информационное взаимодействие, а также сами технологии, обеспечивающие это взаимодействие. Информационное пространство образуется информационными ресурсами, средствами информационного взаимодействия и информационной инфраструктурой. Информационное пространство имеет своим центром субъект, который в процессе своей деятельности создает информацию, присваивает ее, накапливает и передает. Таким субъектом может выступать человек, либо социальная группа, а также компании, органы государственного управления – все, кто в ходе осуществления деятельности использует возможности современных информационных технологий, но в любом случае информационное пространство не может существовать без деятельности человека.

В современном мире, в его информационном аспекте, информационное пространство в связи с развитием технических каналов коммуникации стало практически безграничным, так как в нем неэффективны практически все традиционные ограничения физического пространства – океаны, государственные границы, горы, географическая удаленность. Информационное пространство стирает границы, что является одним из стимулов, и в то же время результатов процессов глобализации. Однако все же информационное пространство имеет свои рамки, обусловленные официальными ограничениями. Эти ограничения бывают конвенциональными - обязывающими соблюдать коммерческую тайну, обеспечивающими право человека на неприкосновенность частной жизни, и институциональными, связанными с государственной и военной тайной.

Структура информационного пространства обусловлена наличием связи между субъектами и объектами, которыми эти субъекты оперируют. Субъекты и объекты с течением времени изменяются, переходят из одних множеств в другие, образуя новые связи и разрушая старые – это обусловливает динамику информационного пространства. Основная проблема заключается в том, что в информационном пространстве структуры фрагментарны, а связи локальны, поэтому субъект информационного пространства иногда может даже не подозревать о существовании другого субъекта, информационно удаленного от него. Эта проблема решается транзитивным замыканием информационного пространства путем добавления к существующему информационному пространству информационной системы, которая содержит глобальную информацию и делает ее доступной всем субъектам информационного пространства.

Объяснение:

0,0(0 оценок)
Ответ:
qwertzasd
qwertzasd
31.12.2020 15:37
// PascalABC.NET 3.0, сборка 1073
const
  nn=30;
  mm=30;
var
  a:array[1..mm,1..nn] of integer;
  m,n,i,j,k,s:integer;
begin
  Writeln('Введите число строк и столбцов массива: '); Read(m,n);
  Randomize;
  Writeln('*** Исходный массив ***');
  k:=0;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(51)-25;
      Write(a[i,j]:4);
      if Odd(a[i,j]) then Inc(k)
    end;
    Writeln
  end;
  if k>5 then begin
    Writeln('Средние арифметические отрицательных элементов по строкам');
    for i:=1 to m do begin
      s:=0; k:=0;
      for j:=1 to n do
        if a[i,j]<0 then begin Inc(k); s:=s+a[i,j] end;
      if k>0 then Writeln(s/k:9:5) else Writeln('  0.00000');
    end
  end
  else begin
    Writeln('*** Результирующий массив ***');
    for i:=1 to m do begin
      for j:=1 to n do begin a[i,j]:=2*a[i,j]; Write(a[i,j]:4) end;
    Writeln
    end
  end
end.

Тестовые решения:
Введите число строк и столбцов массива:
8 6
*** Исходный массив ***
 -16  -8  -1  24 -22   1
  -9 -20 -25  13 -11  10
 -15  10 -12  20 -22   3
  -6  25  -3  25 -14  22
  24  -4  24  17  -4 -17
 -23  -9 -22   1 -18 -13
 -12  13   6 -16   2 -13
  19   8 -22  14  -3   4
Средние арифметические отрицательных элементов по строкам
-11.75000
-16.25000
-16.33333
 -7.66667
 -8.33333
-17.00000
-13.66667
-12.50000

Введите число строк и столбцов массива:
3 5
*** Исходный массив ***
   3  24 -21 -22  -8
 -21  14 -22   0 -22
  15 -16  -2   6  22
*** Результирующий массив ***
   6  48 -42 -44 -16
 -42  28 -44   0 -44
  30 -32  -4  12  44
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота