В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
hehfnfifn
hehfnfifn
10.05.2020 15:14 •  Информатика

Написать программу с шаблонов.
построить список из символов вводимого с клавиатуры текста. вывести на экран первые буквы всех слов входного текста.

Показать ответ
Ответ:
Kachmaresghg
Kachmaresghg
29.06.2020 23:44

ответ:1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

var

 Chislo, Count, Summa, n: integer;

 

begin

 Summa := 0;

 Count := 0;

 readln(Chislo);

 while Chislo > 0 do

 begin

   n := Chislo mod 10;

   if odd(n) then  

   begin

     Summa := Summa + n;

     inc(Count);

   end;

   Chislo := Chislo div 10;

 end;

 writeln('Сумма  нечетных цифр числа: ', Summa);

 writeln('Кол-во нечетных цифр числа: ', Count);

 writeln('Среднее арифметическое  нечетных цифр: ', Summa / Count);

end.

Объяснение:

0,0(0 оценок)
Ответ:
ikaerlapova
ikaerlapova
01.02.2023 17:28
Program pr;
uses crt;

Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;

Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);

if (M>1000) or (N>1000) or (M<1) or (N<1)
then  
Writeln('Ошибка, указанные значения выходят за пределы матрицы')   else   
        Begin      
 Writeln('Введите элементы матрицы');      

k:=0; 
 for i:=1 to N do     
  for j:=1 to M do     
    Begin     
      readln(mas[i,j]);       
      if (mas[i,j] mod 2 = 0) then k:=k+1;     
    end; 
  
    Writeln();   
    Writeln('Исходная матрица');
   
   for i:=1 to N do   
     Begin     
       for j:=1 to M do     
          Begin     
             Write(mas[i,j], ' ')     
           end;     
      Writeln();   
     end;         

Writeln();   
Writeln('Количество четных элементов = ',k);      
 end;

readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота