В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу с объяснением (pascalabc) даны первые 4 строки: 1) 1 2) 112 3) 1121123 4) 112112311211234 и т. д. написать программу выводящую n строку (n< =20)

Показать ответ
Ответ:
юлька438
юлька438
25.08.2020 17:04
Заметим, чтобы сгенерировать строку, нужно знать только предыдущую строку. Будет генерировать по порядку от 1 до n-ой строки.

Программа:

var
  n, i: integer;
  cur_str, prev_str: string;
begin
  read(n);
  prev_str := '';
  for i := 1 to n do {Генерируем строки по порядку от 1 до n}
  begin
    str(i, cur_str); {Записываем в текущую строку её порядковый номер}
    cur_str := prev_str + prev_str + cur_str; {Дописываем предыдущую строку два раза в начало}
    prev_str := cur_str; {Записываем текущею строку вместо предудущей}
  end;
  writeln(cur_str);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота