В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
smolyarrrovav
smolyarrrovav
17.02.2021 04:03 •  Информатика

Написать программу, с которой можно будет найти произведение положительных элементов двумерного массива целых чисел.

Показать ответ
Ответ:
Гюнтер11
Гюнтер11
14.10.2020 00:57

#include<iostream>

using namespace std;

int main()

{

 int n, m;

cin >> n >> m;

int a[n][m];

int answer = 1;

for (int i = 0; i < n; i++)

{

 for (int j = 0; j < m; j++)

 {

     cin >> a[i][j];

     if (a[i][j] > 0)  

     {

       answer *= a[i][j];

     }

 }

}

cout << answer;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота