В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
jokjok1337
jokjok1337
02.08.2021 18:20 •  Информатика

Написать программу с использованием оператора while do вот в начале тренировочного периода лыжник во время тренировки пробегал 5 км,каждый день он увеличивал нагрузку на 5%.рассчитать через какое время нагрузка лыжника во время тренировки превысит 20км

Показать ответ
Ответ:
Anansiy
Anansiy
10.07.2020 19:16
Лучше перепроверить.
0,0(0 оценок)
Ответ:
Violettka181
Violettka181
10.07.2020 19:16
Var 
a, b, c, summ, d, den:real;
beginwrite('Введите кол-во км начальные: ');readln(a);
write('Введите на сколько % увеличивается расстояние каждый день: ');readln(b);
write('Введите, до скольки КМ увеличивает расстояние в день лыжник: ');readln(c);

den:=0;
while a<c do begin  d:=a/100*b; // узнаем, на сколько увеличивается растояние  a:=a+d;  den:=den+1;  end;     writeln(den);
end.

Написал на Pascal. Вводить можно любые данные ( не только, которые вы дали)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота