В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sanik98
sanik98
10.03.2020 02:43 •  Информатика

Написать программу, результат - равна ли сумма цифр введенного положительного числа 10 с защитой от неверного ввода. (неверный вод-если сумма не равна 10 то программа должна заново спросить какие числа он хочет ввести) делать в turbo pascal

Показать ответ
Ответ:
Абвгдежз1234567890
Абвгдежз1234567890
12.06.2020 08:58

function sum (n : integer) : integer;

begin

  sum := 0;

  while n > 0 do

  begin

    sum := sum + n mod 10;

    n := n div 10;

  end;

end;

 

var

  a : integer;

begin

  repeat

    writeln ('a = ');

    read (a);

  until sum (a) = 10;

  writeln ('OK');

end.

0,0(0 оценок)
Ответ:
FinPinKin
FinPinKin
12.06.2020 08:58

var
a,a1,a2:integer;
begin
repeat
writeln (' Введите число');
readln (a);
a1:=a div 10;
a2:=a mod 10;
until (a1+a2=10);
writeln ('Верно ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота