В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ilonazelen
ilonazelen
02.01.2023 22:34 •  Информатика

Написать программу решения задачи в PascalABC: вычислить 1^2+3^2+…+25^2, используя цикл с предусловием

Показать ответ
Ответ:
pupsik101010
pupsik101010
12.03.2020 04:51
#include <iostream>
using namespace std;

int main() {
int a[50][2];
int n;
int k1=0;
int k2=0;
int k3=0;
int k4=0;
cin >> n;
for (int i = 0; i < n; i++) {
cin >> a[i][0] >> a[i][1];
}
for (int i = 0; i < n; i++) {
if (a[i][1]>0)
  if (a[i][0]>0) k1++; else k2++;
 else if (a[i][0]>0) k4++; else k3++;
}
if ((k2>=3)or(k2==2)and(k1>3)or(k3>5)or(k4>9))
 cout << "Clock is broken" << "\n";
 else cout << k2 << k1 << ":" << k3 << k4 << "\n";
return 0;
}

Пример:
10
-1 1
1 1
1 2
-1 -1
-1 -2
-1 -3
1 -1
1 -2
1 -3
1 -4
12:34
0,0(0 оценок)
Ответ:
Лера12435
Лера12435
16.06.2020 23:33
Белов Георгий,
Суворов Дмитрий,
Серёгин Евгений,
Лоскутов Юлий,
Серегина Наташа,
Суворова Евгения.


Решение:

У 2-ой девушки имя как у Серегина
Только 2 имени могут быть как мужским, так и женским - Юлий и Евгений
Серегин не может быть Юлием, т.к. играет не в теннис, а в шахматы, значит Серегин - Евгений, а 2-я девушка - Евгения.  

Наташа была замужем за Евгением, значит можно предположить, что она носит его фамилию => Наташа - Серегина.

Суворов не Евгений (уже занято), не Юлий, т.к. играет в шахматы, а не в теннис, и не Георгий, т.к. из Москвы, а не из Саратова => Суворов - Дмитрий. => 2-я девушка Евгения - Суворова, т.к. ее фамилия, такая же, как у Дмитрия.

Лоскутов из Ярославля, значит он не может быть Георгием => Лоскутов - Юлий.
 
 Остается одна Фамилия Белов и одно имя Георгий => Белов - Георгий
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота