В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
AngelCrazy144
AngelCrazy144
14.12.2020 07:30 •  Информатика

Написать программу расчета функции y=cos(x)*π/x с шагом 0,1 в диапазоне от b до 5, с проверкой диапазона на программу паскаль

Показать ответ
Ответ:
Mazadinec
Mazadinec
01.10.2020 20:22
Var x,y,b:real;
begin
b:=6;
while b>=5 do
  begin
  writeln('Введите параметр b (b<5): ');
  readln(b);
  end;
x:=b;
writeln('x':2,'y':6);
repeat  y:=cos(x)*Pi/x;
  writeln(x:3:1,' ',y);
  x:=x+0.1;
  until x>5;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота