В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Snihdsfg
Snihdsfg
01.02.2023 17:53 •  Информатика

Написать программу при операций div и mod. 1. задано двузначное число. найдите среднее арифметическое цифр числа.

Показать ответ
Ответ:
vadimfroloww
vadimfroloww
05.08.2020 01:49

var  

 a: integer;

 b,c,s: real;

begin

 writeln('Введите число');

 read(a);

 b:=a div 10;

 c:=a mod 10;

 s:=(b+c)/2;

 writeln('Среднее арифметическое: ',s);

end.  

0,0(0 оценок)
Ответ:
plimita134
plimita134
05.08.2020 01:49

var a,b,c:integer;

   s:real;

begin

writeln('Введите двузначное число:');

read(a);

b:=a mod 10;

c:=a div 10;

s:=(b+c)/2;

writeln('Среднее арифметическое: ',s);

end.    

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота