В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
stas2491
stas2491
15.11.2021 16:06 •  Информатика

Написать программу: попугай рома вытягивает каждый из семи дней случайным образом число от 1 до 10. сколько чётных и сколько нечётных чисел он вытянул за неделю.

Показать ответ
Ответ:
tatleb
tatleb
08.10.2020 02:07
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(7,1,10); a.Println;
  var kOdd:=a.Where(t->t.IsOdd).Count;
  Writeln(kOdd,' нечетных, ',7-kOdd,' четных')
end.

Пример
7 2 3 4 2 5 3
4 нечетных, 3 четных
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота