В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vovanik212
Vovanik212
03.12.2022 15:18 •  Информатика

Написать программу получения обратной записи 4 значного числа введенного с клавиатуры

Показать ответ
Ответ:
Var a,b,c,d,e:integer;
begin
writeln('введите четырёхзначное число');
readln(a);
b:=a mod 10;
a:=a div 10;
write(b);
c:=a mod 10;
a:=a div 10;
write(c);
d:=a mod 10;
write(d);
a:=a div 10;
write(a);
end.
0,0(0 оценок)
Ответ:
влад2002ffffffff
влад2002ffffffff
20.07.2020 23:48
// F#

open System;
[<EntryPoint>]
let main argv =
    let rec getNumberFromConsole _ =
        printf "Please enter a correct 4-digits number?\n"
        let maybeInt = Console.ReadLine();
        let mutable value = 0;
        if Int32.TryParse(maybeInt, &value) && value >= 1000 && value <= 9999
            then value
            else (getNumberFromConsole null)
    let rec power = function
        | (x, 0) -> 1
        | (x, n) -> x * power (x, n-1)
    let getDigit sourceNumber digit =
         (sourceNumber / (power (10, digit))) % 10
    let number = getNumberFromConsole null
    let resultNumber = getDigit number 0 * 1000 + getDigit number 1 * 100 + getDigit number 2 * 10 + getDigit number 3
    printf "%d" resultNumber
    Console.ReadKey true |> ignore
    0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота