В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dimalvov1993
dimalvov1993
21.02.2022 09:30 •  Информатика

Написать программу, подсчитывающую количество четных и нечетных цифр в четырехзначном числе . ( в паскале с использованием цикла for)

Показать ответ
Ответ:
4977
4977
03.07.2020 09:51
Var a,b1,b2,c,i:integer;
begin
readln(a);
for i:=1 to 4 do begin
c:=a mod 10;
if c mod 2 = 0 then b1+=1 else
b2+=1;
a:=a div 10;
end;
writeln('Четных - ',b1,' нечетных - ',b2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота