В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Dashamudrik123
Dashamudrik123
23.01.2020 19:36 •  Информатика

Написать программу по информатике: найти произведение положительных, сумму и количество отрицательных из 10 введенных целых чисел.

Показать ответ
Ответ:
Michelle10
Michelle10
04.10.2020 23:55
 program ex; 
var a,k,s,pr,i:integer;mas:array [0..10] of integer; 
begin 
pr:=1; 
for i:=1 to 10 do   
readln(mas[i]); 
 for i:=1 to 10 do   begin   
 if mas[i]>0 then   
  pr:=pr*mas[i]   
 else      s:=s+mas[i]; 
 end; 
 for i:=1 to 10 do  
 begin    
if mas[i]<0 then       k:=k+1;    
end; 
writeln('Произведение=',pr);
 writeln('Сумма=',s); 
writeln('Количество=',k) 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота